[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] Re: [Xen-devel] [PATCH v5 5/9] x86/hvm: add vcpu parameter to guest memory copy function
>>> On 19.01.17 at 18:29, <roger.pau@xxxxxxxxxx> wrote: > --- a/xen/arch/x86/hvm/hvm.c > +++ b/xen/arch/x86/hvm/hvm.c > @@ -3077,15 +3077,16 @@ void hvm_task_switch( > #define HVMCOPY_linear (1u<<2) > static enum hvm_copy_result __hvm_copy( > void *buf, paddr_t addr, int size, unsigned int flags, uint32_t pfec, > - pagefault_info_t *pfinfo) > + pagefault_info_t *pfinfo, struct vcpu *vcpu) Please stick to v as the name here, as done almost everywhere else. It also looks a little odd to me to have this parameter last, when commonly we put it first. For a copy function I can see the buffer info to be first, but please consider moving it ahead of flags. > @@ -3137,12 +3138,12 @@ static enum hvm_copy_result __hvm_copy( > * - 32-bit WinXP (& older Windows) on AMD CPUs for LAPIC accesses, > * - newer Windows (like Server 2012) for HPET accesses. > */ > - if ( !nestedhvm_vcpu_in_guestmode(curr) > - && is_hvm_vcpu(curr) > + if ( !nestedhvm_vcpu_in_guestmode(vcpu) > + && is_hvm_vcpu(vcpu) > && hvm_mmio_internal(gpa) ) This must not be called for v != current. Jan _______________________________________________ Xen-devel mailing list Xen-devel@xxxxxxxxxxxxx https://lists.xen.org/xen-devel
|
Lists.xenproject.org is hosted with RackSpace, monitoring our |