[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] Re: [Xen-devel] [PATCH v5 06/16] x86: implement get hw info flow for MBA
On Sat, Sep 30, 2017 at 01:39:16AM +0000, Yi Sun wrote: > This patch implements get HW info flow for MBA including its callback > function and sysctl interface. > > Signed-off-by: Yi Sun <yi.y.sun@xxxxxxxxxxxxxxx> Reviewed-by: Roger Pau Monné <roger.pau@xxxxxxxxxx> Just one nit below. > --- > CC: Jan Beulich <jbeulich@xxxxxxxx> > CC: Andrew Cooper <andrew.cooper3@xxxxxxxxxx> > CC: Wei Liu <wei.liu2@xxxxxxxxxx> > CC: Roger Pau Monné <roger.pau@xxxxxxxxxx> > CC: Chao Peng <chao.p.peng@xxxxxxxxxxxxxxx> > > v5: > - use ASSERT in 'mba_get_feat_info'. > (suggested by Roger Pau Monné) > - correct initialization format of 'data[PSR_INFO_ARRAY_SIZE]'. > (suggested by Roger Pau Monné and Jan Beulich) > v4: > - remove 'ALLOC_' from macro names. > (suggested by Roger Pau Monné) > - initialize 'data[PSR_INFO_ARRAY_SIZE]' to 0 to prevent to leak stack > data. > (suggested by Roger Pau Monné) > v3: > - replace 'PSR_VAL_TYPE_MBA' to 'PSR_TYPE_MBA_THRTL'. > (suggested by Roger Pau Monné) > v2: > - use 'XEN_SYSCTL_PSR_MBA_LINEAR' to set MBA feature HW info. > (suggested by Chao Peng) > v1: > - sort 'PSR_INFO_IDX_' macros as feature. > (suggested by Chao Peng) > - rename 'PSR_INFO_IDX_MBA_LINEAR' to 'PSR_INFO_IDX_MBA_FLAG'. > - rename 'linear' in 'struct mba_info' to 'flags' for future extension. > (suggested by Chao Peng) > --- > xen/arch/x86/psr.c | 14 +++++++++++++- > xen/arch/x86/sysctl.c | 21 ++++++++++++++++++++- > xen/include/asm-x86/psr.h | 2 ++ > xen/include/public/sysctl.h | 8 ++++++++ > 4 files changed, 43 insertions(+), 2 deletions(-) > > diff --git a/xen/arch/x86/psr.c b/xen/arch/x86/psr.c > index 8520709..66e20a7 100644 > --- a/xen/arch/x86/psr.c > +++ b/xen/arch/x86/psr.c > @@ -263,6 +263,10 @@ static enum psr_feat_type psr_type_to_feat_type(enum > psr_type type) > feat_type = FEAT_TYPE_L2_CAT; > break; > > + case PSR_TYPE_MBA_THRTL: > + feat_type = FEAT_TYPE_MBA; > + break; > + > default: > ASSERT_UNREACHABLE(); > } > @@ -489,7 +493,15 @@ static const struct feat_props l2_cat_props = { > static bool mba_get_feat_info(const struct feat_node *feat, > uint32_t data[], unsigned int array_len) > { > - return false; > + ASSERT( array_len == PSR_INFO_ARRAY_SIZE ); Extra spaces. Thanks, Roger. _______________________________________________ Xen-devel mailing list Xen-devel@xxxxxxxxxxxxx https://lists.xen.org/xen-devel
|
Lists.xenproject.org is hosted with RackSpace, monitoring our |