[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] Re: [Xen-devel] [PATCH for-next 01/16] xen/arm: raw_copy_to_guest_helper: Rename flush_dcache to flags
On Thu, 23 Nov 2017, Julien Grall wrote: > In a follow-up patch, it will be necessary to pass more flags to the > function. > > Rename flush_dcache to flags and introduce a define to tell whether the > cache needs to be flushed after the copy. > > Signed-off-by: Julien Grall <julien.grall@xxxxxxxxxx> Reviewed-by: Stefano Stabellini <sstabellini@xxxxxxxxxx> > --- > xen/arch/arm/guestcopy.c | 8 +++++--- > 1 file changed, 5 insertions(+), 3 deletions(-) > > diff --git a/xen/arch/arm/guestcopy.c b/xen/arch/arm/guestcopy.c > index 4ee07fcea3..2620e659b4 100644 > --- a/xen/arch/arm/guestcopy.c > +++ b/xen/arch/arm/guestcopy.c > @@ -5,8 +5,10 @@ > #include <asm/current.h> > #include <asm/guest_access.h> > > +#define COPY_flush_dcache (1U << 0) > + > static unsigned long raw_copy_to_guest_helper(void *to, const void *from, > - unsigned len, int flush_dcache) > + unsigned len, int flags) > { > /* XXX needs to handle faults */ > unsigned offset = (vaddr_t)to & ~PAGE_MASK; > @@ -24,7 +26,7 @@ static unsigned long raw_copy_to_guest_helper(void *to, > const void *from, > p = __map_domain_page(page); > p += offset; > memcpy(p, from, size); > - if ( flush_dcache ) > + if ( flags & COPY_flush_dcache ) > clean_dcache_va_range(p, size); > > unmap_domain_page(p - offset); > @@ -50,7 +52,7 @@ unsigned long raw_copy_to_guest(void *to, const void *from, > unsigned len) > unsigned long raw_copy_to_guest_flush_dcache(void *to, const void *from, > unsigned len) > { > - return raw_copy_to_guest_helper(to, from, len, 1); > + return raw_copy_to_guest_helper(to, from, len, COPY_flush_dcache); > } > > unsigned long raw_clear_guest(void *to, unsigned len) > -- > 2.11.0 > _______________________________________________ Xen-devel mailing list Xen-devel@xxxxxxxxxxxxxxxxxxxx https://lists.xenproject.org/mailman/listinfo/xen-devel
|
Lists.xenproject.org is hosted with RackSpace, monitoring our |