[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] [PATCH 2/2] x86/E820: improve insn selection

>>> On 12.12.17 at 12:21, <andrew.cooper3@xxxxxxxxxx> wrote:
> On 12/12/17 11:10, Jan Beulich wrote:
>> ..., largely to shrink code size a little:
>> - use TEST instead of CMP with zero immediate
>> - use MOVZWL instead of AND with 0xffff immediate
>> - compute final highmem_bk value in registers, accessing memory just
>>   once
>> Signed-off-by: Jan Beulich <jbeulich@xxxxxxxx>
> Reviewed-by: Andrew Cooper <andrew.cooper3@xxxxxxxxxx>, altbeit it
> preferably with space in the first hunk.

Thanks; similar reason as in the first patch for why I didn't add one.

> Any chance we can drop redundant size suffixes as we go?

This I did consider too, but the file consistently uses size suffixes
everywhere (except on branches, where they're really odd to use;
even gas has special code to make them as unnecessary as
possible there), so I'd rather not start making it mishmash.


Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.