[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] [OSSTEST PATCH v2 07/19] ts-host-install: don't use the new nic naming scheme

On 12/12/17 15:15, Julien Grall wrote:
Hi Wei/Ian,


I have tried this series on Arm64 hardware. I am able to boot and install Debian on AMD Seattle (laxton{0,1}). But I don't get network when using Cavium Thunder-X (rochester{0,1}) after reboot.

Looking into more details, the interface naming is not the same between the installer and after reboot. In the former, eth4 is used whilst the latter uses eth5 for the same interface (USB network dongle).

I have tried to use 'interface force' property to impose eth4, without much luck. The interface naming is still eth5 after reboot.

I was wondering if you have any idea how to solve the naming scheme issue?

I dug a bit more, so 'force interface' will create the /etc/udev/rules.d/70-persistent-net.rules for the installer initrd.

However, it does not get copied to the installed Debian. For the moment, I workaround this by copying the file in overlay/ so it get installed.

With that, I manage to get the network in the installed Debian. I guess this is not the right way. What would be the right way?


Julien Grall

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.