[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] Re: [Xen-devel] [PATCH 3/6] x86: Handle the Xen MSRs via the new guest_{rd, wr}msr() infrastructure
On Mon, Feb 26, 2018 at 05:35:16PM +0000, Andrew Cooper wrote: > Dispatch from the guest_{rd,wr}msr() functions, after falling through from the > !is_viridian_domain() case. > > Rename {rd,wr}msr_hypervisor_regs() to guest_{rd,wr}msr_xen() for consistency, > and because the _regs suffix isn't very appropriate. > > Update them to take a vcpu pointer rather than presuming that they act on > current, and switch to using X86EMUL_* return values. > > Signed-off-by: Andrew Cooper <andrew.cooper3@xxxxxxxxxx> Reviewed-by: Roger Pau Monné <roger.pau@xxxxxxxxxx> > diff --git a/xen/arch/x86/msr.c b/xen/arch/x86/msr.c > index 2ff9361..9f20fd8 100644 > --- a/xen/arch/x86/msr.c > +++ b/xen/arch/x86/msr.c > @@ -183,6 +183,10 @@ int guest_rdmsr(const struct vcpu *v, uint32_t msr, > uint64_t *val) > } > > /* Fallthrough. */ > + case 0x40000200 ... 0x400002ff: > + ret = guest_rdmsr_xen(v, msr, val); > + goto out; > + > default: > return X86EMUL_UNHANDLEABLE; > } > @@ -274,6 +278,10 @@ int guest_wrmsr(struct vcpu *v, uint32_t msr, uint64_t > val) > } > > /* Fallthrough. */ > + case 0x40000200 ... 0x400002ff: A define would be better in order to prevent this two values from getting out of sync with the ones in rdmsr maybe. Thanks, Roger. _______________________________________________ Xen-devel mailing list Xen-devel@xxxxxxxxxxxxxxxxxxxx https://lists.xenproject.org/mailman/listinfo/xen-devel
|
Lists.xenproject.org is hosted with RackSpace, monitoring our |