[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] Re: [Xen-devel] [PATCH 06/11] x86: Reorganise and rename debug register fields in struct vcpu
On Mon, Jun 04, 2018 at 02:59:10PM +0100, Andrew Cooper wrote: > Reusing debugreg[5] for the PV emulated IO breakpoint information is confusing > to read. Instead, introduce a dr7_emul field in pv_vcpu for the pupose. > > With the PV emulation out of the way, debugreg[4,5] are entirely unused and > don't need to be stored. > > Rename debugreg[0..3] to dr[0..3] to reduce code volume, but keep them as an > array because their behaviour is identical and this helps simplfy some of the > PV handling. Introduce dr6 and dr7 fields to replace debugreg[6,7] which > removes the storage for debugreg[4,5]. > > Two minor alterations on the PV side is that merging of the emulated state > happens along with the other dr handling, rather than much later, and > arch_set_info_guest() now checks the return value from set_debugreg() fails > the hypercall rather than silently discarding the values. > > Signed-off-by: Andrew Cooper <andrew.cooper3@xxxxxxxxxx> Reviewed-by: Roger Pau Monné <roger.pau@xxxxxxxxxx> > diff --git a/xen/include/asm-x86/domain.h b/xen/include/asm-x86/domain.h > index 197f8d6..59d5e4a 100644 > --- a/xen/include/asm-x86/domain.h > +++ b/xen/include/asm-x86/domain.h > @@ -500,6 +500,12 @@ struct pv_vcpu > unsigned long shadow_ldt_mapcnt; > spinlock_t shadow_ldt_lock; > > + /* > + * %dr7 bits the guest has set, but aren't loaded into hardware, and are > + * completely emulated. > + */ > + uint32_t dr7_emul; Upper 32bit are reserved ATM, but won't it be better to just use a unsigned long (like it's used below to store the registers)? Roger. _______________________________________________ Xen-devel mailing list Xen-devel@xxxxxxxxxxxxxxxxxxxx https://lists.xenproject.org/mailman/listinfo/xen-devel
|
Lists.xenproject.org is hosted with RackSpace, monitoring our |