[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] Re: [Xen-devel] [PATCH v7 5/6] x86/iommu: switch the hwdom mapping function to use page_get_type
On Wed, Aug 22, 2018 at 09:51:59AM +0200, Roger Pau Monne wrote: > This avoids repeated calls to page_is_ram_type which improves > performance and makes the code easier to read. > > Signed-off-by: Roger Pau Monné <roger.pau@xxxxxxxxxx> > Reviewed-by: Jan Beulich <jbeulich@xxxxxxxx> Reviewed-by: Wei Liu <wei.liu2@xxxxxxxxxx> > --- > Changes since v4: > - New in this version. > --- > Cc: Jan Beulich <jbeulich@xxxxxxxx> > --- > xen/drivers/passthrough/x86/iommu.c | 60 +++++++++++++++-------------- > 1 file changed, 32 insertions(+), 28 deletions(-) > > diff --git a/xen/drivers/passthrough/x86/iommu.c > b/xen/drivers/passthrough/x86/iommu.c > index 25e1ebf8b3..b947ed6043 100644 > --- a/xen/drivers/passthrough/x86/iommu.c > +++ b/xen/drivers/passthrough/x86/iommu.c > @@ -134,6 +134,37 @@ void arch_iommu_domain_destroy(struct domain *d) > { > } > > +static bool __hwdom_init hwdom_iommu_map(const struct domain *d, > + unsigned long pfn, > + unsigned long max_pfn) Consider using type-safe types if possible? Wei. _______________________________________________ Xen-devel mailing list Xen-devel@xxxxxxxxxxxxxxxxxxxx https://lists.xenproject.org/mailman/listinfo/xen-devel
|
Lists.xenproject.org is hosted with RackSpace, monitoring our |