[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] Re: [Xen-devel] [PATCH] drivers/block/xen-blkback/common.h: use DIV_ROUND_UP instead of reimplementing its function
Adding Julien how did the work to support XEN_PAGE_SIZE != PAGE_SIZE. On Wed, Sep 12, 2018 at 02:14:26AM -0600, Jan Beulich wrote: > >>> On 12.09.18 at 07:45, <zhongjiang@xxxxxxxxxx> wrote: > > --- a/drivers/block/xen-blkback/common.h > > +++ b/drivers/block/xen-blkback/common.h > > @@ -65,7 +65,7 @@ > > (XEN_PAGES_PER_INDIRECT_FRAME / XEN_PAGES_PER_SEGMENT) > > > > #define MAX_INDIRECT_PAGES \ > > - ((MAX_INDIRECT_SEGMENTS + SEGS_PER_INDIRECT_FRAME - > > 1)/SEGS_PER_INDIRECT_FRAME) > > + DIV_ROUND_UP(MAX_INDIRECT_SEGMENTS, SEGS_PER_INDIRECT_FRAME) > > #define INDIRECT_PAGES(_segs) DIV_ROUND_UP(_segs, > > XEN_PAGES_PER_INDIRECT_FRAME) > > My first reaction was to suggest > > #define MAX_INDIRECT_PAGES INDIRECT_PAGES(MAX_INDIRECT_SEGMENTS) > > but that wouldn't match what's there currently (note the two different > divisors). I can't really decide whether that's just unfortunate naming > of the two macros, or an actual bug. I think there's indeed a bug here. AFAICT, MAX_INDIRECT_PAGES should use XEN_PAGES_PER_INDIRECT_FRAME and then it could be changed as Jan suggested. Current MAX_INDIRECT_PAGES is misnamed and should instead be MAX_INDIRECT_SEGS (which on x86 is exactly the same because PAGE_SIZE == XEN_PAGE_SIZE). Roger. _______________________________________________ Xen-devel mailing list Xen-devel@xxxxxxxxxxxxxxxxxxxx https://lists.xenproject.org/mailman/listinfo/xen-devel
|
Lists.xenproject.org is hosted with RackSpace, monitoring our |