[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] Re: [Xen-devel] [PATCH v10 5/7] memory: add check_get_page_from_gfn() as a wrapper...
Hi Paul, On 09/18/2018 05:56 PM, Paul Durrant wrote: ...for some uses of get_page_from_gfn(). There are many occurrences of the following pattern in the code: q = <readonly look-up> ? P2M_ALLOC : P2M_UNSHARE; page = get_page_from_gfn(d, gfn, &p2mt, q); if ( p2m_is_paging(p2mt) ) { if ( page ) put_page(page); p2m_mem_paging_populate(d, gfn); return <-EAGAIN or equivalent>; } if ( (q & P2M_UNSHARE) && p2m_is_shared(p2mt) ) { if ( page ) put_page(page); return <-EAGAIN or equivalent>; } if ( !page ) return <-EINVAL or equivalent>; There are some small differences between the exact way the occurrences are coded but the desired semantic is the same. This patch introduces a new common implementation of this code in check_get_page_from_gfn() and then converts the various open-coded patterns into calls to this new function. NOTE: There are duplicate declarations of check_get_page_from_gfn() for ARM and x86 because the function takes a p2m_type_t argument and that type is architecture specific. Wouldn't it be possible to move #include p2m-common.h later on in p2m.h? Cheers, -- Julien Grall _______________________________________________ Xen-devel mailing list Xen-devel@xxxxxxxxxxxxxxxxxxxx https://lists.xenproject.org/mailman/listinfo/xen-devel
|
Lists.xenproject.org is hosted with RackSpace, monitoring our |