[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] [PATCH 3/4] x86: reduce code duplication in guest_remove_page()

>>> On 20.11.18 at 18:06, <andrew.cooper3@xxxxxxxxxx> wrote:
> On 20/11/2018 16:19, Jan Beulich wrote:
>> Quite a bit of duplicate code has accumulated on the "paging" types
>> special case path. Re-use what can be re-used from the common path.
>> Since it needs touching anyway, slightly re-format and extend the
>> gdprintk() on the common path as well.
>> Signed-off-by: Jan Beulich <jbeulich@xxxxxxxx>
> Doesn't this negate the previous patch?  I'm afraid that I'm rather
> confused.

No - please note the new "obtain_page" label that the code branches
to, which replaces what the earlier patch has introduced. Beyond this
code replacement the patch here simply leverages that "page" would
then be NULL throughout the remaining part of this special path, and
hence all respective conditionals and code can go away. It merely
seemed to me that doing the overall transformation in two steps would
be better; in principle the change here could be merged into the
earlier patch.


Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.