[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] [PATCH v5 4/7] xen: introduce mfn_init macro

>>> On 03.12.18 at 22:03, <sstabellini@xxxxxxxxxx> wrote:
> To be used in constant initializations of mfn_t variables, such as:
> static mfn_t node = mfn_init(MM_ADDR);
> It is necessary because static inline functions cannot be used as static
> initializers.

We had been at this point once (quite some time ago), and got
away without such an addition. Did you try to find that old
discussion? Are there any new reasons to have such a construct?
Do you need this for other than setting a value to INVALID_MFN,
in which case INVALID_MFN_INITIALIZER ought to be suitable?

This is not to say I'm entirely opposed.

If we were to have such a construct, I wonder though whether
mfn_init() is suitable as a name. Simply MFN() perhaps, and then
also consistently have GFN() and DFN()?


Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.