[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] [PATCH v2 09/18] xsm, argo: XSM control for argo register; add argo_mac bootparam



>>> On 20.12.18 at 07:39, <christopher.w.clark@xxxxxxxxx> wrote:
> --- a/xen/common/argo.c
> +++ b/xen/common/argo.c
> @@ -35,6 +35,22 @@ DEFINE_XEN_GUEST_HANDLE(xen_argo_ring_t);
>  static bool __read_mostly opt_argo_enabled;
>  boolean_param("argo", opt_argo_enabled);
>  
> +/* Xen command line option for conservative or relaxed access control */
> +bool __read_mostly argo_mac_bootparam_enforcing = true;

Please can you follow our naming convention, which would
make this something like opt_argo_mac_enforcing?

And then - except in the parsing function, the variable is never
used.

> +static int __init parse_argo_mac_param(const char *s)
> +{
> +    if ( !strcmp(s, "enforcing") )
> +        argo_mac_bootparam_enforcing = true;
> +    else if ( !strcmp(s, "permissive") )
> +        argo_mac_bootparam_enforcing = false;
> +    else
> +        return -EINVAL;
> +
> +    return 0;
> +}
> +custom_param("argo_mac", parse_argo_mac_param);

New command line options need to be accompanied by an
addition to docs/misc/xen-command-line.markdown.

Also we've more or less settled on using dashes instead of
underscores in new command line options.

Jan



_______________________________________________
Xen-devel mailing list
Xen-devel@xxxxxxxxxxxxxxxxxxxx
https://lists.xenproject.org/mailman/listinfo/xen-devel

 


Rackspace

Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.