[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [Xen-devel] [OSSTEST PATCH 36/62] TestSupport: target_somefile_leaf rename and change a variable
Rename this function. `getleaf' contains `get' which makes it sound like the function copies something, or returns answers suitable for getting, or something. Also rename `$rdest' to `$rfile' since it might be a source too. (Although we are not about to make it a source...) Signed-off-by: Ian Jackson <ian.jackson@xxxxxxxxxxxxx> --- Osstest/TestSupport.pm | 10 +++++----- 1 file changed, 5 insertions(+), 5 deletions(-) diff --git a/Osstest/TestSupport.pm b/Osstest/TestSupport.pm index 4e2f120a..a5870e4d 100644 --- a/Osstest/TestSupport.pm +++ b/Osstest/TestSupport.pm @@ -504,10 +504,10 @@ sub remote_perl_script_done ($) { !$? or die "$thing->{What} $?"; } -sub target_somefile_getleaf ($$$) { - my ($lleaf_ref, $rdest, $ho) = @_; +sub target_somefile_leaf ($$$) { + my ($lleaf_ref, $rfile, $ho) = @_; if (!defined $$lleaf_ref) { - $$lleaf_ref= $rdest; + $$lleaf_ref= $rfile; $$lleaf_ref =~ s,.*/,,; } $$lleaf_ref= hostnamepath($ho)."--$$lleaf_ref"; @@ -602,7 +602,7 @@ sub target_install_packages_norec ($@) { sub tpfcs_core { my ($tputfilef,$ho,$timeout,$filedata, $rdest,$lleaf) = @_; - target_somefile_getleaf(\$lleaf,$rdest,$ho); + target_somefile_leaf(\$lleaf,$rdest,$ho); my $h= new IO::File "$stash/$lleaf", 'w' or die "$lleaf $!"; print $h $filedata or die $!; @@ -654,7 +654,7 @@ sub teditfileex { if (!defined $rdest) { $rdest= $rfile; } - target_somefile_getleaf(\$lleaf,$rdest,$ho); + target_somefile_leaf(\$lleaf,$rdest,$ho); my $lfile; for (;;) { -- 2.11.0 _______________________________________________ Xen-devel mailing list Xen-devel@xxxxxxxxxxxxxxxxxxxx https://lists.xenproject.org/mailman/listinfo/xen-devel
|
Lists.xenproject.org is hosted with RackSpace, monitoring our |