[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] [PATCH v2 02/10] xen: rename un/map_mmio_regions to un/map_regions

On Thu, 2 May 2019, Jan Beulich wrote:
> >>> On 30.04.19 at 23:02, <sstabellini@xxxxxxxxxx> wrote:
> > Now that map_mmio_regions takes a p2mt parameter, there is no need to
> > keep "mmio" in the name. The p2mt parameter does a better job at
> > expressing what the mapping is about. Let's save the environment 5
> > characters at a time.
> But as per the cover letter the purpose is to allow mapping
> iomem (which I take is just an alternative term for MMIO).
> Even if that's misleading, {,un}map_regions() is a little too
> unspecific for my taste. At which point at least the
> environment saving argument goes away ;-)

Honestly, I am not one to care for functions names. As long as the other
maintainers agree with each others, I am happy to make the required

> As to the series as a whole, I guess you first want to come
> to an agreement with Julien. Only then it'll make sense to
> actually review the changes, I think.

Fair enough, but I don't think Julien and I have such a big disagreement
on the shape of the series. (He still needs to complete his review of v2

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.