[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] [PATCH 15/20] xen/arm: mm: Use the shorter version __aligned(PAGE_SIZE) to align page-tables





On 03/05/2019 16:58, Andrii Anisov wrote:


On 22.04.19 19:49, Julien Grall wrote:
We currently use the very long version __attribute__((__aligned(4096)))
to align page-tables. Thankfully there is a shorter version to make

IMO it is better to change `version` to `macro`. In order to specify it is not a compiler specific but specific to XEN.

I will reword to "Thankfully Xen provides an handy macro that will make the code more readable".


the code more readable.

While modifying the attribute:
     1) Move it before the variable name as we do in other part of Xen
     2) Switch to PAGE_SIZE instead of 4096 to make more future-proof
     3) Mark static page-tables not used outside the file (i.e any
        page-tables other than boot_* and xen_fixmap).

Lastly, some of the variables use __attribute__(__aligned(X * 4096)).
However this is not necessary as page-tables are only required to be
to be aligned to a page-size. So use __aligned(PAGE_SIZE).

Signed-off-by: Julien Grall <julien.grall@xxxxxxx>
Though:

Reviewed-by: Andrii Anisov <andrii_anisov@xxxxxxxx>


Cheers,

--
Julien Grall

_______________________________________________
Xen-devel mailing list
Xen-devel@xxxxxxxxxxxxxxxxxxxx
https://lists.xenproject.org/mailman/listinfo/xen-devel

 


Rackspace

Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.