[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] Compiling Xen error on RedHat8.0

On Fri, 24 May 2019, Chen, Farrah wrote:

> Hi,
> I met some python related issues when building Xen on RedHat8.0.
> On RedHat8.0, the default python version is python3, and I found Xen has some 
> python2 codes, so I tried to build xen using python2.
> On RedHat8.0, no "python", just "python2" and "python3":
> ls /usr/bin/python*
> /usr/bin/python2    /usr/bin/python2.7-config  /usr/bin/python3    
> /usr/bin/python3.6-config  /usr/bin/python3.6m-config         
> /usr/bin/python3-config
> /usr/bin/python2.7  /usr/bin/python2-config    /usr/bin/python3.6  
> /usr/bin/python3.6m        /usr/bin/python3.6m-x86_64-config
> So I created a soft link "python" to "python2":
> ll /usr/bin/python
> lrwxrwxrwx 1 root root 16 May 24 13:08 /usr/bin/python -> /usr/bin/python2
> Then I tried to build xen:
> cd xen
> ./configure --enable-ovmf
> .........
> checking for unistd.h... yes
> checking for python-config... no
> checking Python.h usability... yes
> checking Python.h presence... yes
> checking for Python.h... yes
> checking for PyArg_ParseTuple... no
> configure: error: Unable to find a suitable python development library
> configure: error: ./configure failed for tools
> If I use python3(create a soft link "python" to "python3" ), it reported 
> syntax error.
> checking for unistd.h... yes
> checking for python-config... no
>   File "<string>", line 1
>     import distutils.sysconfig;         print "-I" + 
> distutils.sysconfig.get_config_var("INCLUDEPY")
>                                                  ^
> SyntaxError: invalid syntax
> checking Python.h usability... no
> checking Python.h presence... no
> checking for Python.h... no
> configure: error: Unable to find Python development headers
> configure: error: ./configure failed for tools
> To resolve "Unable to find a suitable python development library", I 
> installed python2-devel*, python2-lib*, python3-devel*, python3-lib*, 
> python2-six, python3-six, but this error still exists.
> In RedHat7, these packages are called "python-devel*, python-lib*", but in 
> RedHat8, these packages don't exists, RedHat8 has only "python2-devel*, 
> python2-lib*, python3-devel*, python3-lib*", maybe Xen codes cannot identify 
> them.
> Do you have any advice on building Xen on RedHat8? Thanks a lot!

If you want to go down the python3 path there are a bundle of python3 
packages (from the xen master branch) in the Fedora build of xen-4.12.0 at
which might be useful to apply or refer to given that RHEL 8 is loosely 
based on Fedora.

Also RHEL 8 has python36-devel and python2-devel which you might need for 
a python3 or python2 build.

        Michael Young

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.