[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] [PATCH 2/2] dom_cow is needed for mem-sharing only

On Fri, 31 May 2019, Julien Grall wrote:
> Hi Jan,
> On 31/05/2019 11:46, Jan Beulich wrote:
> > > > > On 31.05.19 at 12:34, <julien.grall@xxxxxxx> wrote:
> > > No it was a more generic statement on the stance "It already exists in
> > > Xen so it is fine to spread them a bit more".
> > 
> > Oh, I see. Of course I'm making remarks when what's in the tree is
> > bad (as per e.g. coding style, or if not mentioned there than in my
> > personal opinion). As a result I take note of you thinking this being
> > bad practice, and the two of us disagreeing. I'm certainly willing to
> > adjust non-obvious code to a more obvious shape in various cases,
> > but I think there needs to be a limit as to what language features
> > we decide should not be used in the code base. Overriding
> > declarations (and in some cases even definitions) by macros is a
> > useful thing for general readability in certain cases in my opinion,
> > and while it's not making much of difference here I'd still prefer if
> > I was allowed to get away with this, unless a majority supports
> > your view. IOW - your change request is, as per my own
> > perspective, making the code less easy to read, even if not by
> > much.
> Let will wait the opinion from the others here.

My preference is what Andrew suggested:

  extern struct domain *dom_cow;
  define dom_cow NULL

and I find Jan's original version harder to read. However, for code
style related things, I prefer to "suggest" to other maintainers one way
or the other, rather than "request" for a change.

If something bother us enough to do something about it, the way to go is
to send a patch to CODING_STYLE so that we are all on the same page.

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.