[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Re: [Xen-devel] [PATCH V3 1/9] block: add a helper function to read nr_setcs
- To: Chaitanya Kulkarni <chaitanya.kulkarni@xxxxxxx>, linux-block@xxxxxxxxxxxxxxx
- From: Bart Van Assche <bvanassche@xxxxxxx>
- Date: Wed, 3 Jul 2019 08:03:27 -0700
- Cc: damien.lemoal@xxxxxxx, linux-btrace@xxxxxxxxxxxxxxx, linux-scsi@xxxxxxxxxxxxxxx, konrad.wilk@xxxxxxxxxx, yuchao0@xxxxxxxxxx, colyli@xxxxxxx, linux-bcache@xxxxxxxxxxxxxxx, jaegeuk@xxxxxxxxxx, xen-devel@xxxxxxxxxxxxxxxxxxxx, kent.overstreet@xxxxxxxxx, roger.pau@xxxxxxxxxx
- Delivery-date: Wed, 03 Jul 2019 15:03:50 +0000
- List-id: Xen developer discussion <xen-devel.lists.xenproject.org>
On 7/2/19 10:42 AM, Chaitanya Kulkarni wrote:
+/* Helper function to read the bdev->bd_part->nr_sects */
+static inline sector_t bdev_nr_sects(struct block_device *bdev)
+{
+ return part_nr_sects_read(bdev->bd_part);
+}
Is the comment above bdev_nr_sects() really useful or should it be left out?
Thanks,
Bart.
_______________________________________________
Xen-devel mailing list
Xen-devel@xxxxxxxxxxxxxxxxxxxx
https://lists.xenproject.org/mailman/listinfo/xen-devel
|