[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] [PATCH 2/8] x86/cpuid: Split update_domain_cpuid_info() in half

On 11.09.2019 22:04, Andrew Cooper wrote:
> update_domain_cpuid_info() currently serves two purposes.  First to merge new
> CPUID data from the toolstack, and second, to perform any necessary updating
> of derived domain/vcpu settings.
> The first part of this is going to be superseded by a new and substantially
> more efficient hypercall.
> Carve the second part out into a new domain_cpu_policy_changed() helper, and
> call this from the remains of update_domain_cpuid_info().
> This does drop the call_policy_changed, but with the new hypercall hypercall

duplicate "hypercall"

> in place, the common case will be a single call per domain.  Dropping the
> optimisation here allows for a cleaner set of following changes.
> Signed-off-by: Andrew Cooper <andrew.cooper3@xxxxxxxxxx>

Reviewed-by: Jan Beulich <jbeulich@xxxxxxxx>
with one purely cosmetic remark:

> @@ -317,27 +193,104 @@ static int update_domain_cpuid_info(struct domain *d,
>              d->arch.pv.cpuidmasks->e1cd = mask;
>          }
> +    }
> +
> +    for_each_vcpu( d, v )

Valid spelling is "for_each_vcpu ( d, v )" (as it was in the original
code) or "for_each_vcpu(d, v)" depending on whether you consider
"for_each_vcpu" a (pseudo-)keyword. I'd like to ask that we don't gain
further hybrid spellings.


Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.