[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] [PATCH v2 21/48] xen/sched: use sched_resource cpu instead smp_processor_id in schedulers

On 12.09.2019 13:53, Juergen Gross wrote:
> On 12.09.19 13:46, Jan Beulich wrote:
>> On 12.09.2019 13:17, Juergen Gross wrote:
>>> On 12.09.19 12:04, Jan Beulich wrote:
>>>> On 12.09.2019 11:34, Juergen Gross wrote:
>>>>> Okayy, I'll rename "cpu" to "my_cpu".
>>>> We've got a number of instances of "this_cpu" in such cases already,
>>>> but no single "my_cpu". May I suggest to stick to this naming here
>>>> as well?
>>> Hmm, don't you think adding further overloading of "this_cpu" is a bad
>>> idea?
>> Not at all, no. A function-like macro and a variable of the same
>> name will happily coexist.
> I am aware that this is working correctly.
> I just think such overloading isn't helping for readability and ease
> of modification.
> In the end I'm not feeling strong here, so in case there are no
> objections I'll go with this_cpu.

Okay, so let's consider another alternative: cur_cpu? What I
sincerely dislike are identifiers of the my_* form, for being
apparently common in absolute beginner examples.


Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.