[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] [PATCH 08/35] libxl: Replace libxl__qmp_initializations by ev_qmp calls



Anthony PERARD writes ("[PATCH 08/35] libxl: Replace libxl__qmp_initializations 
by ev_qmp calls"):
> Setup a timeout of 10s for all the commands. It used to be about 5s
> per commands.
> 
> The order of command is changed, we call 'query-vnc' before
> 'change-vnc-password', but that should not matter. That makes it
> easier to call 'change-vnc-password' conditionally.
> 
> Also 'change' command is replaced by 'change-vnc-password'
> because 'change' is deprecated. The new command is available in all
> QEMU versions that also have Xen support.

Thanks.  I reviewed this and indeed there are some other significant
changes, particularly to coding style.  Overall it is all an
improvement.  At least, everything that I saw seemed like an
improvement...

> +        /* Check if the "label" start with "serial". */
> +        if (!label || strncmp(label, serial, seriall))
> +            continue;
> +        port = strtol(label + seriall, &endptr, 10);
> +        if (*(label + seriall) == '\0' || *endptr != '\0') {
> +            LOGD(ERROR, qmp->domid,
> +                 "Invalid serial port number: %s", label);
> +            rc = ERROR_QEMU_API;
> +            goto out;

This open-coded string mangling is quite awkward but I don't have a
better suggestion and this kind of open-coded strtoul call seems very
common already.  (And it was there before, too.)

So, overall:

Acked-by: Ian Jackson <ian.jackson@xxxxxxxxxxxxx>

Thanks,
Ian.

_______________________________________________
Xen-devel mailing list
Xen-devel@xxxxxxxxxxxxxxxxxxxx
https://lists.xenproject.org/mailman/listinfo/xen-devel

 


Rackspace

Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.