[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Question about xen and Rasp 4B

On Sat, Jan 23, 2021 at 3:00 AM Roman Shaposhnik <roman@xxxxxxxxxx> wrote:
On Fri, Jan 22, 2021 at 4:27 PM Stefano Stabellini
<sstabellini@xxxxxxxxxx> wrote:
> + xen-devel, Roman,
> On Fri, 22 Jan 2021, Jukka Kaartinen wrote:
> > Hi Stefano,
> > I'm Jukka Kaartinen a SW developer working on enabling hypervisors on mobile platforms. One of our HW that we use on development is
> > Raspberry Pi 4B. I wonder if you could help me a bit :).
> >
> > I'm trying to enable the GPU with Xen + Raspberry Pi for dom0. https://www.raspberrypi.org/forums/viewtopic.php?f=63&t=232323#p1797605
> >
> > I got so far that GPU drivers are loaded (v3d & vc4) without errors. But now Xen returns error when X is starting:
> > (XEN) traps.c:1986:d0v1 HSR=0x93880045 pc=0x00007f97b14e70 gva=0x7f7f817000 gpa=0x0000401315d000
> >  I tried to debug what causes this and looks like find_mmio_handler cannot find handler.
> > (See more here: https://www.raspberrypi.org/forums/viewtopic.php?f=63&t=232323&start=25#p1801691 )
> >
> > Any ideas why the handler is not found?
> Hi Jukka,
> I am glad to hear that you are interested in Xen on RaspberryPi :-)  I
> haven't tried the GPU yet, I have been using the serial only.
> Roman, did you ever get the GPU working?

I've never tested it with X -- sorry. But I have to ask what kernel is being
used? It made a lot of difference for me to actually STOP using RPi
supplied kernels and switch directly to 5.10.7.
I'm using rpi-5.9.y -branch from https://github.com/raspberrypi/linux.
I tried to use rpi-5.10.y but with that raspberry is not booting up.

Jukka Kaartinen



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.