[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PATCH v7 6/6] PCI: Make use of pci_resource_n()



On Fri, Mar 24, 2023 at 10:08:39AM +0100, Philippe Mathieu-Daudé wrote:
> On 23/3/23 18:36, Andy Shevchenko wrote:
> > Replace open-coded implementations of pci_resource_n() in pci.h.

...

> >   #define pci_resource_n(dev, bar)  (&(dev)->resource[(bar)])
> > -#define pci_resource_start(dev, bar)       ((dev)->resource[(bar)].start)
> > -#define pci_resource_end(dev, bar) ((dev)->resource[(bar)].end)
> > -#define pci_resource_flags(dev, bar)       ((dev)->resource[(bar)].flags)
> > -#define pci_resource_len(dev,bar) \
> > -   ((pci_resource_end((dev), (bar)) == 0) ? 0 :    \
> > -                                                   \
> > -    (pci_resource_end((dev), (bar)) -              \
> > -     pci_resource_start((dev), (bar)) + 1))
> > +#define pci_resource_start(dev, bar)       (pci_resource_n(dev, 
> > bar)->start)
> > +#define pci_resource_end(dev, bar) (pci_resource_n(dev, bar)->end)
> > +#define pci_resource_flags(dev, bar)       (pci_resource_n(dev, 
> > bar)->flags)
> > +#define pci_resource_len(dev,bar)                                  \
> > +   (pci_resource_end((dev), (bar)) ?                               \
> > +    resource_size(pci_resource_n((dev), (bar))) : 0)
> 
> Seems (to me) more logical to have this patch as "PCI: Introduce
> pci_resource_n()" ordered before your patch #2 "PCI: Introduce
> pci_dev_for_each_resource()".

Either way works for me. Bjorn, what do you like?

> Here as #6 or as #2:
> Reviewed-by: Philippe Mathieu-Daudé <philmd@xxxxxxxxxx>

Thank you!

-- 
With Best Regards,
Andy Shevchenko





 


Rackspace

Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.