[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] Re: [PATCH block/for-next v2 01/16] block: add a new helper to get inode from block_device
Hi, 在 2023/11/27 15:21, Christoph Hellwig 写道: On Mon, Nov 27, 2023 at 02:21:01PM +0800, Yu Kuai wrote:From: Yu Kuai <yukuai3@xxxxxxxxxx> block_devcie is allocated from bdev_alloc() by bdev_alloc_inode(), and currently block_device contains a pointer that point to the address of inode, while such inode is allocated together:This is going the wrong way. Nothing outside of core block layer code should ever directly use the bdev inode. We've been rather sloppy and added a lot of direct reference to it, but they really need to go away and be replaced with well defined high level operation on struct block_device. Once that is done we can remove the bd_inode pointer, but replacing it with something that pokes even more deeply into bdev internals is a bad idea. Thanks for the advice, however, after collecting how other modules are using bdev inode, I got two main questions: 1) Is't okay to add a new helper to pass in bdev for following apis? If so, then almost all the fs and driver can avoid to access bd_inode dirctly. errseq_check(&bdev->bd_inode->i_mapping->wb_err, wb_err); errseq_check_and_advance(&bdev->bd_inode->i_mapping->wb_err, &wb_err); mapping_gfp_constraint(bdev->bd_inode->i_mapping, gfp); i_size_read(bdev->bd_inode) find_get_page(bdev->bd_inode->i_mapping, offset); find_or_create_page(bdev->bd_inode->i_mapping, index, gfp); read_cache_page_gfp(bdev->bd_inode->i_mapping, index, gfp); invalidate_inode_pages2(bdev->bd_inode->i_mapping); invalidate_inode_pages2_range(bdev->bd_inode->i_mapping, start, end); read_mapping_folio(bdev->bd_inode->i_mapping, index, file); read_mapping_page(bdev->bd_inode->i_mapping, index, file); balance_dirty_pages_ratelimited(bdev->bd_inode->i_mapping) file_ra_state_init(ra, bdev->bd_inode->i_mapping);page_cache_sync_readahead(bdev->bd_inode->i_mapping, ra, file, index, req_count); inode_to_bdi(bdev->bd_inode) 2) For the file fs/buffer.c, there are some special usage like following that I don't think it's good to add a helper: spin_lock(&bd_inode->i_mapping->private_lock); Is't okay to move following apis from fs/buffer.c directly to block/bdev.c? __find_get_block bdev_getblk Thanks, Kuai .
|
Lists.xenproject.org is hosted with RackSpace, monitoring our |