[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] Re: [PATCH 05/17] xen/x86: address violations of MISRA C:2012 Directive 4.10
On 2024-07-01 16:21, Jan Beulich wrote: On 01.07.2024 15:36, Alessandro Zucchelli wrote:--- a/xen/arch/x86/Makefile +++ b/xen/arch/x86/Makefile@@ -260,17 +260,18 @@ $(objtree)/arch/x86/include/asm/asm-macros.h: $(obj)/asm-macros.i $(src)/Makefil$(call filechk,asm-macros.h) define filechk_asm-macros.h + guard=$$(echo ASM_${SRCARCH}_ASM_MACROS_H | tr a-z A-Z); \Nit: Hard tab slipped in.+ echo '#ifndef $$guard'; \ + echo '#define $$guard'; \ echo '#if 0'; \ echo '.if 0'; \ echo '#endif'; \ - echo '#ifndef __ASM_MACROS_H__'; \ - echo '#define __ASM_MACROS_H__'; \ echo 'asm ( ".include \"$@\"" );'; \ - echo '#endif /* __ASM_MACROS_H__ */'; \ echo '#if 0'; \ echo '.endif'; \ cat $<; \ - echo '#endif' + echo '#endif'; \ + echo '#endif /* $$guard */' endef $(obj)/efi.lds: AFLAGS-y += -DEFI --- a/xen/arch/x86/cpu/cpu.h +++ b/xen/arch/x86/cpu/cpu.h @@ -1,3 +1,6 @@ +#ifndef X86_CPU_CPU_H +#define X86_CPU_CPU_HThis, ...--- a/xen/arch/x86/x86_64/mmconfig.h +++ b/xen/arch/x86/x86_64/mmconfig.h @@ -5,6 +5,9 @@ * Author: Allen Kay <allen.m.kay@xxxxxxxxx> - adapted from linux */ +#ifndef X86_64_MMCONFIG_H +#define X86_64_MMCONFIG_H... this, and ...--- a/xen/arch/x86/x86_emulate/private.h +++ b/xen/arch/x86/x86_emulate/private.h @@ -6,6 +6,9 @@ * Copyright (c) 2005-2007 XenSource Inc. */ +#ifndef X86_X86_EMULATE_PRIVATE_H +#define X86_X86_EMULATE_PRIVATE_H... this guard can't possibly all follow the same proposed naming scheme (wherever the final version of that is being recorded; I don't recall ithaving gone in, and I didn't spot anything earlier in the series); at least one must be wrong. For x86/x86_64/mmconfig.h has been made an exception as stated in the commit message: Note that in x86_64/mmconfig.h we slightly deviate from the naming convention in place: instead of having the inclusion guard as X86_X86_64_MMCONFIG_H we shortened the directory prefix as X86_64 for the sake of readability.If you do not agree with this exception and you prefer to keep the additional X86_ prefix let me know so as I prepare the patch series V5 I may reintroduce it. Best regards, -- Alessandro Zucchelli, B.Sc. Software Engineer, BUGSENG (https://bugseng.com)
|
Lists.xenproject.org is hosted with RackSpace, monitoring our |