[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] Re: [PATCH v2 01/22] x86/include/asm/intel-txt.h: constants and accessors for TXT registers and heap
On Wed, May 21, 2025 at 05:19:57PM +0200, Jan Beulich wrote: > > +/* > > + * The same set of registers is exposed twice (with different permissions) > > and > > + * they are allocated continuously with page alignment. > > + */ > > +#define NR_TXT_CONFIG_SIZE \ > > + (TXT_PUB_CONFIG_REGS_BASE - TXT_PRIV_CONFIG_REGS_BASE) > > What does the NR_ in the identifier try to express? That's a leftover from the original name inside tboot.c, I'll rename it to TXT_CONFIG_SPACE_SIZE. > > +/* > > + * Secure Launch defined OS/MLE TXT Heap table > > + */ > > +struct txt_os_mle_data { > > + uint32_t version; > > + uint32_t reserved; > > + uint64_t slrt; > > + uint64_t txt_info; > > + uint32_t ap_wake_block; > > + uint32_t ap_wake_block_size; > > + uint8_t mle_scratch[64]; > > +} __packed; > > This being x86-specific, what's the __packed intended to achieve here? This structure is passed to Xen by a bootloader, __packed makes sure the structure has a compatible layout. > > +/* > > + * TXT specification defined BIOS data TXT Heap table > > + */ > > +struct txt_bios_data { > > + uint32_t version; /* Currently 5 for TPM 1.2 and 6 for TPM 2.0 */ > > + uint32_t bios_sinit_size; > > + uint64_t reserved1; > > + uint64_t reserved2; > > + uint32_t num_logical_procs; > > + /* Versions >= 3 && < 5 */ > > + uint32_t sinit_flags; > > + /* Versions >= 5 with updates in version 6 */ > > + uint32_t mle_flags; > > + /* Versions >= 4 */ > > + /* Ext Data Elements */ > > +} __packed; > > It does affect sizeof() here, which I'm unsure is going to matter. It doesn't hurt anything and makes sure offsets match those in the specification. > > +static inline uint64_t txt_bios_data_size(void *heap) > > Here, below, and in general: Please try to have code be const-correct, i.e. > use pointers-to-const wherever applicable. I assume this doesn't apply to functions returning `void *`. The approach used in libc is to accept pointers-to-const but then cast the constness away for the return value, but this header isn't a widely-used code. > > +{ > > + return *((uint64_t *)heap) - sizeof(uint64_t); > > For readability it generally helps if excess parentheses like the ones here > are omitted. OK. > > +static inline uint64_t txt_os_mle_data_size(void *heap) > > +{ > > + return *((uint64_t *)(txt_bios_data_start(heap) + > > + txt_bios_data_size(heap))) - > > + sizeof(uint64_t); > > This line wants indenting a little further, such that the"sizeof" aligns > with the start of the expression. (Same elsewhere below.) > > Jan Will update. Regards
|
![]() |
Lists.xenproject.org is hosted with RackSpace, monitoring our |