[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: [Xen-users] NFS Root FS Prob

> I have my disk file stored on a NFS server.
> I have tried these two approaches:
> A) Mounting the NFS directory in RW mode on a local directory 
> and specifying in my config file the complete path of my disk file.
>     xm create configFile returned with this error:
>     Error: Error creating domain: vbd: Segment not found: 
> uname=file:/MountPoint/diskfile

I know a number of people that use such a setup, but I wouldn't
recommend it. Using a loopback file stored over NFS can cause serious
memory pressure in dom0 under high write load (it's a native Linux

To figure out what's going wrong for you, use losetup to attach the file
to a loop device manually, then use phy:loopX in the vbd setup.
> B) As per docs, I then tried NFS Root:
>     I removed the disk="" line from my config file and put in
>     root = "/dev/nfsd"
>     nfs_server = "IP"
>     nfs_root = "/PathOfDiskFile/OnNfsServer"
>     I have already pre-configured static ip, netmask, gateway etc
>     I am getting these errors during domain boot-up:
>     VFS: Unable to mount root fs via NFS, trying floppy.
>     VFS: Cannot open root device "nfsd" or unknown-block(2,0)
>     Please append a correct "root=" boot option
>     Kernel panic - not syncing: VFS: Unable to mount root fs on
> unknown-block(2,0)
>     <0>Rebooting in 1 seconds..

Shoot be root=/dev/nfs


Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.