[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] installation of Xen binary on Fedora 2 with LVM


In /etc/fstab I have:

/dev/VolGroup00/LogVol00 /                       ext3    defaults        1 1
So I tried booting without initrd like thus:

kernel /xen.gz dom0_mem=131072
module /vmlinuz-2.6.10-xen0 root=/dev/VolGroup00/LogVol00 ro console=tty0

And I get the following message:

Root-NFS: no NFS server available,giving up
VFS: Unable to mount root fs via NFS,trying floppy
VFS: Insert root floppy and press enter

And when I press enter I see
kernel panic (not syncing...)
(I did not catch the rest)
and it reboots.

I want to add that when I boot the fedora I have

kernel /vmlinuz-2.6.9-1.667 ro root=/dev/VolGroup00/LogVol00 rhgb quiet
initrd /initrd-2.6.9-1.667.img

In case I should use mkinitrd - should I run it with
mkinitrd initrd_file_name .img 2.6.9-1.667 (2.6.9-1.667 is the original version of the Fedora kernel I have)
Or should it be somehow connected to the Xen kernel
vmlinuz-2.6-xen0 I have
something like
mkinitrd initrd_file_name .img 22.6-xen0 ?

(I don't know much on mkinitrd).

Any ideas?


From: Mark Williamson <mark.williamson@xxxxxxxxxxxx>
To: xen-users@xxxxxxxxxxxxxxxxxxx
CC: sting sting <zstingx@xxxxxxxxxxx>
Subject: Re: [Xen-users] installation of  Xen binary on Fedora 2 with LVM
Date: Fri, 29 Apr 2005 17:46:16 +0100

> The first was:
>     kernel /xen.gz dom0_mem=131072
>     module /vmlinuz-2.6.10-xen0 root=LABEL=/ ro console=tty0
>     It says the it can't find the / (root) and looks for a
>     floppy or an NFS root. (I don't have a floppy at all and there is
>     no floppy entry in /etc/fstab).
>     Then it ask me to press any key, and when I do so - it reboots.

You can't use the LABEL=/ syntax unless you have an initrd.  However, you
could look up the partition number of the root device in /etc/fstab and use
that instead. (e.g. something like root=/dev/hda2).

That should work on FC2.

> In the second I added one line:
>     module /initrd-2.6.9-1.667.img
> The initrd-2.6.9-1.667.img is the original Fedora imitrd file (is it
> OK to use it ?)

You'd need to build a new initrd using mkinitrd. You can probably do without
on FC2, however.


Xen-users mailing list

Don't just search. Find. Check out the new MSN Search! http://search.msn.com/

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.