[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] No networkcard with Xen2.0.6 (3C940)

I use this same network and when I was using xen stable there was no
problem with it. But I would say what is going on is this: when you run
make world, it cleans your kernel tree and everything else that was
compiled before in your xen dir, so it erases your .config that had this
module (or bultin). After you change options for xen0 kernel, do make
dist or make kbuild at xen main dir, then install with ./install.sh or
make install. If you are really sure it compiled within the xen0 kernel
(I doubt this if you ran make world) try loading (module: sk98lin).

On Tue, 2005-05-31 at 12:06 +0200, opensource@xxxxxx wrote:
> Hi List,
> I have an installtion of Ubuntu 5.04 and try to get Xen running.
> Xen boots fine except that an ifconfig tells me only the loopback device
> is present.
> I think the driver for my OnBoard Networkcard 3C940 is not built in.
> Can anyone tell me how to solve this issue?
> I have tried to compile form source which has the same result.
> I tried to prepare the Kernel for me like the Documentation told me:
> " make ARCH=xen xconfig "
> I selected the Yukon Marvel Driver which supports the 3C940 Card.
> a " cd .. " and " make " gives me the output that there is no rule for make.
> I also edited the defconfig file for xen0. make world compiles fine. I
> see the driver during compiling.
> But still the same issue.
> Please anyone help me.
> Kind Regards
> Dennis Erlach
> _______________________________________________
> Xen-users mailing list
> Xen-users@xxxxxxxxxxxxxxxxxxx
> http://lists.xensource.com/xen-users

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.