[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: [Xen-users] Serial port module in Xen

> I'm running the linux kernel with Xen 2.0.6 with 
> serial driver compiled as a module. Unfortunately I can't 
> modprobe the module 8250.ko:
> FATAL: Error inserting 8250 (/lib/.../8250.ko): Device or 
> resource busy

Try booting with xencons=off on the kernel command line and make sure
that Xen isn't claiming the serial console.

> dmesg only says:
> Serial: 8250/16550 driver $Revision: 1.90 $ 48 ports, IRQ 
> sharing enabled
> I have tried as well with 2.0-testing, with share_irqs=0 
> option to the module, passed xencons=off to dom0 kernel, 
> tried to insmod it from initrd to prevent any other driver 
> from taking the device, but had no luck at all.
> The serial driver is modularized because that's the way SuSE ships it.
> However the problem exists in vanilla with 
> xen-2.0-testing as well so it isn't a SuSE-specific issue.
> Is there a workaround for this problem? Or is it known 
> problem and I'll have to recompile the kernel with static 
> serial driver?
> Thanks!
> Michal Ludvig
> _______________________________________________
> Xen-users mailing list
> Xen-users@xxxxxxxxxxxxxxxxxxx
> http://lists.xensource.com/xen-users

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.