[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] Problem with XEN and CONFIG_XEN_PHYSDEV_ACCESS


I have a problem using CONFIG_XEN_PHYSDEV_ACCESS. I want to access a network adapter directly from a Domain != 0 (Router domain). So I enabled CONFIG_XEN_PHYSDEV_ACCESS and PCI support in the kernel. But then I can't start the domain anymore, even if I don't select any hardware driver in the kernel config.

My .config-File for the Domain can be found at

-- Shell Output --
# xm create -f router  -c
Using config file "/etc/xen/router".
Started domain Router, console on port 9633
************ REMOTE CONSOLE: CTRL-] TO QUIT ********

************ REMOTE CONSOLE EXITED *****************
-- /Shell Output --

-- xen config file --
kernel = "/boot/vmlinuz-2.6.11-xenU-router"
memory = 64
name = "Router"
disk = [ 'file:/vm/router,sda1,w' ]
root = "/dev/sda1 ro"
-- /xen config file --

The output of xend.log and xend-debug.log can be found at

I really have no clue what's wrong.. I tried to enable/disable PCI-support, to switch off networking for this Domain, ... nothing worked. Is it somehow possible to get more debug output?

I use xen 2.0.7, self-compiled on a debian sarge.

Thanks for help,

Sebastian Roesner

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.