[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] Warning: unable to open an initial console

Aaron // LT wrote:
I am very sorry for this nonsense... this was my first attempt at using CentOS 4.1 with Xen. The reason for the error was the udev issue (as explained for FedoraCore 3) in the wiki. Perhaps I should add some lines there... ?

So the problem was solved by:
mkinitrd --builtin=ata_piix /boot/initrd-
and adding the initrd to the grub configuration.

Thanks, did that get it working for you? I'm guessing its the SCSI controller which is causing the problems, I'll see if I can do a similar step for the SCSI controller...

Yes, it worked for me. Short explaination:

Similar to what is described here, the problem is udev:

Before udev is started, /dev/console, /dev/null etc. do not exist in the root file system. The solution is to use an initial ram disk that contains these entries.

To create an initrd for the xen kernels do:

cd /lib/modules     # look for the correct kernel version
depmod    # create module dependencies if missing

# create the initrd image
mkinitrd /boot/initrd-

If mkinitrd complains that it can't find a specific module (from /etc/modules.conf), and you know that it is compiled into the kernel directly, you can tell mkinitrd so. E.g. for the ata_piix module:
mkinitrd --builtin=ata_piix /boot/initrd-

Then add an additional line to the grub.conf file for the correct kernel:
module /initrd-
or module /boot/initrd- if you don't have a boot partition.

Hope that helps. With this additional step, both Xen 2.0.7 and the latest unstable builds work well on this hardware with CentOS 4.1.

Best Regards,
Michael Paesold

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.