[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] domU device access : kernel problem

  • To: <xen-users@xxxxxxxxxxxxxxxxxxx>
  • From: "Waeyenbergh, Sven" <Sven.Waeyenbergh@xxxxxxxxxxxxxx>
  • Date: Fri, 4 Nov 2005 10:12:25 +0100
  • Cc: Markus Schuster <ma.schuster@xxxxxx>
  • Delivery-date: Fri, 04 Nov 2005 09:17:47 +0000
  • List-id: Xen user discussion <xen-users.lists.xensource.com>
  • Thread-index: AcXgyuUfV+TG6TAOTkmcMlOn4R5j3QAUb9Kw
  • Thread-topic: [Xen-users] Re: domU device access : kernel problem

Hi all,

I finally managed to get my kernel booting.

It seems like when your are accessing hardware directly from a domU kernel, you 
but you also need to enable CONFIG_XEN_PRIVILEGED_GUEST for the kernel to boot.

Please note that there are several steps to get this to work : 

1. find the device (or devices - some cards have more then 1) by running lspci 
on dom0
2. hide devices from dom0 by specifying the physdev_dom0_hide kernel option at 
the xen-2.0.gz kernel command line 
                example : kernel /xen-2.0.gz dom0_mem=131072 
3. give your domU kernel hardware access by specifying 
CONFIG_XEN_PHYSDEV_ACCESS in your domU kernel config
4. enable CONFIG_XEN_PRIVILEGED_GUEST in your domU kernel config - do not know 
why, but seems needed to boot
5. enable the drivers you need in the domU kernel config - both the device 
drivers and the bus drivers
                example : for a tvcard: CONFIG_I2C, 
                note that making modules here is easy for debugging 
5. if you made modules, copy them to the domU filesystem
6. make the domU kernel and edit the config file to boot from it
7. give the domU access to the specified devices by adding pci=['x,y,z'] in you 
domain config file
                example: pci = ['03,02,1','03,02,0']

and boot tha booty ...

Hope it helps,

-----Original Message-----
From: Markus Schuster [mailto:ma.schuster@xxxxxx]
Sent: 04 November 2005 00:00
To: xen-users@xxxxxxxxxxxxxxxxxxx
Subject: [Xen-users] Re: domU device access : kernel problem

Waeyenbergh, Sven schrieb:
> i needed a custom kernel (i want to play with PCI device acces in domU) so i 
> grabbed the 2.0.7 source
> and compiled the 2.6.11-domU kernel (with the standard config) and tried 
> booting one of my 2.0.6 systems.
> result : 
> debian:/mnt/temp/xen/xenU/xen-2.0/linux-2.6.11-xenU# xm create  
> /etc/xen/mythtv -c
> Using config file "/etc/xen/mythtv".
> Started domain mythtv, console on port 9618
> ************ REMOTE CONSOLE: CTRL-] TO QUIT ********
> ************ REMOTE CONSOLE EXITED *****************
> .... eg : nothing at all

That looks exactly like the problem I reported about 2 month ago under
the topic "What's the magic to compile a unified dom0 and domU kernel
image?". Very nice to see that I'm not the only one with problems like
this. I think there MUST be some type of bug in the XEN 2.0.7 (?) code.

I just tried with my failing kernel config: When disabling
CONFIG_XEN_PHYSDEV_ACCESS the domU comes up, otherwise not.


*** eSafe scanned this email for malicious content ***
*** IMPORTANT: Do not open attachments from unrecognized senders  ***
This electronic transmission and any files attached to it are strictly 
confidential and intended solely for the addressee. If you are not 
the intended addressee, you must not disclose, copy or take any
action in reliance of this transmission. If you have received this 
transmission in error, please notify the sender by return and delete
the transmission.  Although the sender endeavors to maintain a
computer virus free network, the sender does not warrant that this
transmission is virus-free and will not be liable for any damages 
resulting from any virus transmitted. 
Thank You.

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.