[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] Re: domU device access : kernel problem

Waeyenbergh, Sven schrieb:
> i needed a custom kernel (i want to play with PCI device acces in domU) so i 
> grabbed the 2.0.7 source
> and compiled the 2.6.11-domU kernel (with the standard config) and tried 
> booting one of my 2.0.6 systems.
> result : 
> debian:/mnt/temp/xen/xenU/xen-2.0/linux-2.6.11-xenU# xm create  
> /etc/xen/mythtv -c
> Using config file "/etc/xen/mythtv".
> Started domain mythtv, console on port 9618
> ************ REMOTE CONSOLE: CTRL-] TO QUIT ********
> ************ REMOTE CONSOLE EXITED *****************
> .... eg : nothing at all

That looks exactly like the problem I reported about 2 month ago under
the topic "What's the magic to compile a unified dom0 and domU kernel
image?". Very nice to see that I'm not the only one with problems like
this. I think there MUST be some type of bug in the XEN 2.0.7 (?) code.

I just tried with my failing kernel config: When disabling
CONFIG_XEN_PHYSDEV_ACCESS the domU comes up, otherwise not.


Attachment: signature.asc
Description: OpenPGP digital signature

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.