[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] xen-2.0 questions

  • To: xen-users@xxxxxxxxxxxxxxxxxxx
  • From: Sipos Ferenc <frank@xxxxxxx>
  • Date: Sat, 05 Nov 2005 12:23:05 +0100
  • Delivery-date: Sat, 05 Nov 2005 11:23:16 +0000
  • List-id: Xen user discussion <xen-users.lists.xensource.com>

Hi All,

I'm new to Xen, and as probably many of us, have encountered some
problems I cannot overcome myself. I first tried to find answers to my
questions at the #xen unofficial freenode channel, also checked FAQ, but
no luck so far.

/Please note, I'm using CC=gcc-3.4 & ARCH=xen during the compilations on
a ia32 based machine/

1. In my dom0, whenever I try to compile NVIDIA driver for my VGA card,
the compilation itself finishes flawlessly, but when it tries to insert
the module, it gives me segfault. I tried different version of the
driver (newer, older) w/o any success. My dom0 kernel is a custom kernel
config with "access to physical hardware" enabled.

For an output of `make CC=gcc-3.4 install ARCH=xen`, `modprobe nvidia`
and the relevant portion of dmesg, please see the following file.


2. I know it's kind of a minor thing compared to the overall feeling
that xen provides me, so I don't consider it to be a bug, but I want to
be sure it is something not implemented yet instead of me doing
something wrong.

I'd like to have a 1024x768 framebuffered console for my dom0 domain.
Whenever I pass "vga=791" to the kernel command line, but it does not
take any effect. I'm suspecting it might be cause of the presence of
"console=tty0", so as a test, I changed it to "console=vga", but no luck

Any suggestions are welcome, and appreciated.


Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.