[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] Dell 2650

A follow up in the interests of completeness and putting some info in the archive.

I now have it working - disabled the USB, modified kernel config as suggested below. Also found that having SMP enabled Dom0 kernel caused problems (occasional boot lockups) so run non SMP. Interestingly the DomU kernels _HAVE_ to be SMP or they fail to find the root device (no idea why that is).

Config I used for Gentoo:

Set RC_NET_STRICT_CHECKING="none" in /etc/conf.d/rc.d


config_xenbr0=( " netmask broadcast" )
routes_xenbr0=("default via")

Then add xenbr0 to the default run level.

System is now up and running well. Have one issue in that xm top (or xentop) gives me a segmentation fault, but that's not a big problem.

Thanks for the assistance.

Ernst Bachmann wrote:
On Friday 11 November 2005 20:15, David Brain wrote:

I'm having some problems getting a Xen Dom0 running on a Dell Powedge
2650.  I'm using xen 3.0.0_pre20051027 with 2.6.12 patched xen sources.

Problem is that it detects the SCSI controller, but the driver does not
initialize the disks.

The controller is an Adaptec AIC-7899P

[from lspci]
0000:05:06.0 SCSI storage controller: Adaptec AIC-7899P U160/m (rev 01)
0000:05:06.1 SCSI storage controller: Adaptec AIC-7899P U160/m (rev 01)

Works under plain linux using the 'Adaptec AIC7xxx Fast -> U160 (new

Under xen the boot never progresses past:

scsi0 : Adaptec AIC7XXX EISA/VLB/PCI SCSI HBA DRIVER, Rev 6.2.36
        <Adaptec aic7899 Ultra160 SCSI adapter>
        aic7899: Ultra160 Wide Channel A, SCSI Id=7, 32/253 SCBs

Then does not detect the discs, and sits cyling scsi resets.

I also tried the old AIC7 driver with similar results.

Any thoughts as to how to progress (or kernel config hints)..

Could you check /proc/interrupts wether the IRQ is shared with some other device, maybe the USB controller?

There were quite some reports of dell hardware causing trouble unless you deactivate USB in the bios, maybe try that.

About the kernel config: I had a similar problem with a xen-3 snapshot, the SCSI controller (LSI Megaraid) wouldn't receive interrupts and cycle through scsi resets in an endless loop.
(uniprocessor kernel for dom0 on a dual Xeon system with HT)

I disabled "PCI Express support" and "Message Signaled Interrupts (MSI and MSI-X)" and enabled "Local APIC support on uniprocessors" + "IO-APIC support on uniprocessors" in "Bus options (PCI, PCMCIA, EISA, MCA, ISA)" under "X86 Processor Configuration" which caused it to work again.

Unfortunately I didn't bother to check which of those four options acutally fixed it, but my guess would be the IO-APIC (the board doesn't have PCI Express)...


David Brain  -  Bandwidth.com
(919) 297 1078

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.