[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: [Xen-users] Problem with my UMTS card

Mats Petersson wrote:

>Is the driver for this card a generic driver supplied with the Linux
> distribution, or do you download the driver separately?
> There are some drivers that aren't included in the OS that does things
> in "unconventional ways". Those drivers will not work in a
> Para-virtualized driver (including Xen Dom0). [And drivers that are
> included in the OS may still do things in unconventional ways and
> therefore need "fixing" to work with Xen, if these drivers aren't
> commonly used in a Xen environment - maybe no-one has tried them in Xen
> before...]
> Do you see any error messages in dmesg or xm dmesg that may be of some
> help?

I have compiled this Dom0 kernel with the basic settings but I had to add some 
for pcmcia, ppp and serial and I can't see an error in dmesg ... xm dmesg stops 
the line:

  Serial input->DOM0 (type 'CTRL-a' three times to switch input to Xen).

because I've disabled the serial console in grub.conf.

The UMTS card seems to be a "simple" serial modem on /dev/ttyS3 that uses 
orinary modules:

Module                  Size  Used by
ppp_deflate             4768  0
zlib_deflate           22520  1 ppp_deflate
ppp_async               9536  1
crc_ccitt               1664  1 ppp_async
ppp_generic            25716  6 ppp_deflate,ppp_async
slhc                    5920  1 ppp_generic
serial_cs               8168  1
8250                   34500  4 serial_cs
serial_core            22560  1 8250
pcmcia                 22824  9 serial_cs
yenta_socket           20232  3
rsrc_nonstatic         11520  1 yenta_socket
pcmcia_core            44068  4 serial_cs,pcmcia,yenta_socket,
agpgart                30216  0

and it doesn't share an interrupt with an other device:

[root@tivoli ~]# cat /proc/interrupts
  1:         91        Phys-irq  i8042
11:       3770        Phys-irq  CS46XX, yenta, yenta, serial
12:        896        Phys-irq  i8042
14:       6136        Phys-irq  ide0
15:       2268        Phys-irq  ide1
256:      11863     Dynamic-irq  timer0
257:          0     Dynamic-irq  xenbus
258:          0     Dynamic-irq  net-be-dbg
NMI:          0
LOC:          0
ERR:          0
MIS:          0

I remeber, that I had a similar problem when I moved from kernel version 2.4
to 2.6 on redhat 9. I had to disable /proc/sys/net/ipv4/tcp_ecn to get a 
connection to the internet (icmp also worked, but no http possible).

I have also tried other versions of Xen (stable | testing) and other kernel
versions (2.6.11 | 2.6.12), but non of them works.


Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.