[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] Xen 3.0 and Gentoo: basic network issues

On Tuesday 07 February 2006 16:45, Nathan Tibbetts wrote:
> Hi all
>   I just joined the mailing list becuase I've run into a problem that I've
> found absolutely no solution for and that no one else seems to have ever
> had either. I'm running Gentoo with a 2.6.15 kernel on an IBM x306 and I
> installed Xen 3.0 from the portage tree.
>   Now I was able to configure and compile a dom0 and domU kernel, boot into
> Xen using the dom0 kernel and start a vm using the domU kernel.
>   My issue is that I have no network connection whatsoever. I have two
> ethernet ports built into the server that are Intel pro/1000 Gigabit ports.
> When I boot to the normal Gentoo kernel, they both work fine I can set IP
> addresses and get a connection, I can run dhcp and get a connection, etc.
> However, under the Xen kernel, they refuse to work. Now I've tried
> disabling starting xend on startup just to see before any bridging and
> virtual interface stuff got set if the ports work, but they still don't.
> I've also tried just about anything else that might even be remotely
> related. I'm not sure what kind of outputs would be helpful in solving this
> problem, so just let me know what kind of information is needed and I'll
> post it up as soon as I get a chance.
>   Thanks in advance for any assistance.

Obvious things first:
does your xen0 kernel have the network drivers for eepro1000, as module or 

do they show up in "ifconfig -a", "lsmod", "lspci"?

also, you'll most likely need to set RC_NET_STRICT_CHECKING to "lo" or "no" 
in /etc/conf.d/rc, otherwise /etc/init.d/xend start might deadlock.


Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.