[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] vlan problems


I'm trying to get several vlan interfaces working with bridging using
Xen 3.0. The (dom0) system is Debian testing with Xen 3.0-testing using
packages from packages.debianbase.de.

eth0 is a normal interface and works fine (also with the Xen bridge).
eth1 contains several vlans (eth1.1234, eth1.3001, ..., eth1.3008),
where the dom0 needs to use one of these vlans (eth1.1234) for NFS, ...

I have used a wrapper script calling the network-bridge script with
what seemed like reasonable parameters, but dom0 always looses
connectivity on eth1.1234. Also, none of the domU's seemed to have
connectivity on any of the vlans. The same setup and a very similar
wrapper script worked for Xen 2.0.

Configuration of the interfaces in dom0 is in /etc/network/interfaces,
relevant parts:
auto eth0
iface eth0 inet static

auto eth1.1234
iface eth1.1234 inet static

auto eth1.3001
iface eth1.3001 inet static
        post-up ifconfig eth1.3001

auto eth1.3002
iface eth1.3002 inet static
        post-up ifconfig eth1.3002

The script calling network-bridge looks as follows:

$script "$@" netdev=eth0   vifnum=0 bridge=xen-br-e0
$script "$@" netdev=eth1.1234 vifnum=9 bridge=xen-br-e1
$script "$@" netdev=1.3001 vifnum=1 bridge=xen-br-3001
$script "$@" netdev=1.3002 vifnum=2 bridge=xen-br-3002
$script "$@" netdev=1.3003 vifnum=3 bridge=xen-br-3003
$script "$@" netdev=1.3004 vifnum=4 bridge=xen-br-3004
$script "$@" netdev=1.3005 vifnum=5 bridge=xen-br-3005
$script "$@" netdev=1.3006 vifnum=6 bridge=xen-br-3006
$script "$@" netdev=1.3007 vifnum=7 bridge=xen-br-3007
$script "$@" netdev=1.3008 vifnum=8 bridge=xen-br-3008

After running the script, connectivity on eth1.1234 is gone. Doing
ifup eth1.1234 again seems to fix the problem for dom0, but not for the
bridge and domU's.

If I try
        # /etc/xen/scripts/network-bridge start netdev=eth1.1234
I get the following output
        vifnum=9 bridge=xen-br-e1
        Removed VLAN -:eth1.1234:-
        SIOCSIFNAME: No such device
so I'm not sure if the network-bridge script is supposed to work for
vlan interfaces at all.

I have also tried to use the old networking script from Xen 2.0, but it
did not seem to work (it used to work with Xen 2.0). Has something
insideXen been changed or should it be possible to use the old script as

Any help would be appreciated.

Best regards,

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.