[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] probs running stuff from initrd

Hello all

Now I may be way of whack here, so please forgive me.

I'm trying to merge xen with redhat's config-netboot. The idea being a kinda stateless domU. For those that haven't seen you share a rootfs and then bind mount all the individual files over then top, and the redhat gui builds all the pxeboot config and stuff for you if you want a diskless client. I thought this would be nice for our domU's but obviously
don't need the pxe bit.

I've got nfsroot domU's working, and was just wondering if it would be possible to mount the diskless initrd and run the diskless script from inside that.

First of all what do you think root should equal. For nfsroot you set it to /dev/nfs but the pxeconfig that get produced uses /dev/ram0

I've also set this

ramdisk = "/tftpboot/linux-install/RHEL4.1/initrd.img"

and then tried to pass init=disklessrc

But it does this ( with root= /dev/ram0 ):-

RAMDISK: ext2 filesystem found at block 0
RAMDISK: Loading 5000KiB [1 disk] into ram disk... done.
VFS: Mounted root (ext2 filesystem).
Freeing unused kernel memory: 184k freed
Warning: unable to open an initial console.
Kernel panic - not syncing: No init found. Try passing init= option to kernel.

Now that initrd has got a console (and a null) and I've tried passing various init= lines but nothing works. I've also tried rebuilding the initrd with links to init and linuxrc, but nothing.

What would I need to pass as a root= to be able to get it to run something in the initrd?

Sorry if none of this makes any sense.

Cheers for any help


Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.