[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: [Xen-users] probs running stuff from initrd

  • To: xen@xxxxxxxxxx, xen-users@xxxxxxxxxxxxxxxxxxx
  • From: "Petersson, Mats" <Mats.Petersson@xxxxxxx>
  • Date: Mon, 3 Apr 2006 18:49:57 +0200
  • Delivery-date: Mon, 03 Apr 2006 10:01:02 -0700
  • List-id: Xen user discussion <xen-users.lists.xensource.com>
  • Thread-index: AcZXPSUDihGzzznnTHGX4fG9Nmm8YQAAQhXg
  • Thread-topic: [Xen-users] probs running stuff from initrd

> -----Original Message-----
> From: xen-users-bounces@xxxxxxxxxxxxxxxxxxx 
> [mailto:xen-users-bounces@xxxxxxxxxxxxxxxxxxx] On Behalf Of 
> xen@xxxxxxxxxx
> Sent: 03 April 2006 17:39
> To: xen-users@xxxxxxxxxxxxxxxxxxx
> Subject: [Xen-users] probs running stuff from initrd
> Hello all
> Now I may be way of whack here, so please forgive me.
> I'm trying to merge xen with redhat's config-netboot. The 
> idea being a kinda stateless domU. For those that haven't 
> seen you share a rootfs and then bind mount all the 
> individual files over then top, and the redhat gui builds all 
> the pxeboot config and stuff for you if you want a diskless 
> client. I thought this would be nice for our domU's but 
> obviously don't need the pxe bit.
> I've got nfsroot domU's working, and was just wondering if it 
> would be possible to mount the diskless initrd and run the 
> diskless script from inside that.
> First of all what do you think root should equal. For nfsroot 
> you set it to /dev/nfs but the pxeconfig that get produced 
> uses /dev/ram0
> I've also set this
> ramdisk = "/tftpboot/linux-install/RHEL4.1/initrd.img"
> and then tried to pass init=disklessrc
> But it does this ( with root= /dev/ram0 ):-
> RAMDISK: ext2 filesystem found at block 0
> RAMDISK: Loading 5000KiB [1 disk] into ram disk... done.
> VFS: Mounted root (ext2 filesystem).
> Freeing unused kernel memory: 184k freed
> Warning: unable to open an initial console.
> Kernel panic - not syncing: No init found.  Try passing init= 
> option to kernel.
> Now that initrd has got a console (and a null) and I've tried 
> passing various init= lines but nothing works. I've also 
> tried rebuilding the initrd with links to init and linuxrc, 
> but nothing.
> What would I need to pass as a root= to be able to get it to 
> run something in the initrd?

The problem isn't with trying to run something in initrd [at least not
directly], but most likely failing when the system tries to mount your
"root" directory (/). 

It's either missing the /dev/<something> that you've said is "/", or
it's missing some driver needed to access this. 

I've seen this a fair number of times (both on my own system, due to
missing /dev/something or due to missing driver) and people on this list
suffering the same thing. 

You may need to compile more stuff into your XenU kernel to make it work

Of course, I could be wrong... :-)

> Sorry if none of this makes any sense.
> Cheers for any help
> Lee
> _______________________________________________
> Xen-users mailing list
> Xen-users@xxxxxxxxxxxxxxxxxxx
> http://lists.xensource.com/xen-users

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.