[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] Error: (2, 'No such file or directory')

  • To: xen-users@xxxxxxxxxxxxxxxxxxx
  • From: Morten Christensen <mc-xen@xxxxx>
  • Date: Sun, 16 Apr 2006 15:24:23 +0200
  • Delivery-date: Sun, 16 Apr 2006 06:25:46 -0700
  • List-id: Xen user discussion <xen-users.lists.xensource.com>

Peter Fokkinga skrev den 15-04-2006 16:50:
Quoting Morten Christensen <mc-xen@xxxxx>:
It's strange, I get exactly the same traceback in xend.log when
I run `/etc/init.d/xend start` when directory /var/run/xenstored
is missing. But I get no "xend" processes (just "[xenwatch]" and

When you do `xm list`, you don't get any errors, do you?

xm list
Error: Error connecting to xend: No such file or directory. Is xend running?

That is consistent with what I am seeing. Could you try:

1. /etc/init.d/xendomains stop ; /etc/init.d/xend stop
2. mkdir /var/run/xenstored
3. rm /var/log/xen*
4. /etc/init.d/xend start

Now check /var/log/xen/xend.log and/or try `xm list` again.

If this still doesn't help then I'm out of ideas :-(

Now I have come a bit further.

If I:
Stop xend
Create /var/run/xenstored
Start xend
Run 'xm list' or ' xm crate -c vmo0.cfg'

then I do not get the error.

Every time I reboot, then /var/run/xenstored is deleted.
If xend is started without an existing xenstored, than it does not work.
If I stop xend, create xenstored and start xend, then I do not get theis error.

How are you starting xend ?

Thank you for your help.

Morten Christensen

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.