[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] Dom0 searching for NFS root

  • To: xen-users@xxxxxxxxxxxxxxxxxxx
  • From: "Sugeng Widodo" <sugeng.widodo@xxxxxxxxx>
  • Date: Mon, 17 Apr 2006 11:12:19 +0700
  • Delivery-date: Sun, 16 Apr 2006 21:12:53 -0700
  • Domainkey-signature: a=rsa-sha1; q=dns; c=nofws; s=beta; d=gmail.com; h=received:message-id:date:from:to:subject:in-reply-to:mime-version:content-type:content-transfer-encoding:content-disposition:references; b=WPlLS3sGm8Q9e1ULfZRgb4Z5GkjNl9Y+NVWrBJZDwdFhETQMvdnpZ4+dCU9EmIZPSvMVjfVgzgqagMaUfwM1l7LS6t5pAsEEHdak12BUR1sN+RgLqcjkWajTInq4RZTuUjqnHoaFxt3rJz2hlcYtwfZgJKFoRXeeW2KvqHPfUnc=
  • List-id: Xen user discussion <xen-users.lists.xensource.com>

On 4/16/06, Simon <greminn@xxxxxxxxx> wrote:
> On 4/15/06, Sugeng Widodo <sugeng.widodo@xxxxxxxxx> wrote:
> > Dear all,
> >
> > I've installed Xen 3.0.1 on my laptop and dom0 is boot normaly execpt
> > it's could not using X, i haven't trying to boot guest OS. my laptop
> > configuration is Toshiba Portege R150 with Debian Sarge on it.
> > And then I installed same version of Xen into our server with Debian
> > Sarge and Kernel 2.4. Booting dom0 is not success , xen always trying
> > look dor NFS root and then request for floopy , anybody experience
> > with this syndrome ?
> > In this server I use hde as the harddisk and boot partition is hde1
> > and root partition at hde10 , is this the problem for Xen ?
> I had this problem also when installing xen 3.0.x on a IBM xSeries
> server, the issue was that when i installed debian with the 2.4
> kernel, it saw the SATA hard drive as /dev/hdX, where as the 2.6 xen
> kernel saw it as /dev/sdX. Once i changed the grub menu.lst file from:
> module      /boot/xen-linux- root=/dev/hda1 ro
> to..
> module      /boot/xen-linux- root=/dev/sda1 ro
> it worked fine. Here is the full grub kernel options BTW:
> title       Xen 3.0.0 - Linux
> kernel      /boot/xen-3.0.1.gz dom0_mem=262144
> module      /boot/xen-linux- root=/dev/sda1 ro
> module      /boot/xen-modules-
> Dont know if this is the same issue for you, but this is how i got it working.
> Simon

Yes I have exactly same problem and it solved like yours, thanks alot.
Now I must thinking the compatibility with original distro (debian)
which knowing the disk as /dev/hde because I have to modify the fstab
( I use multiple partition for my system).


Sugeng Widodo
blog : http://elangmaya.lensa.or.id/

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.