[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] General question on running guests from installed OS


First of all apologies for making all of you read this long email.  I have 
posted to multiple lists to get my setup running.  Inspite of enthusiastic help 
I have not got it running yet and hence this fundamental doubt.

I had a system running FC4 and Xen 2.x.  The same system had normal 
installations of Suse and Ubuntu.  I had a running setup wherin I started xen0 
in FC4 and was able to run the installed Suse and Ubuntu as guests within FC4.  
(This worked perfectly and I was able to connect to the guests using both 
RealVNC and FreeNX.)

I have now upgraded to FC and have been attempting to get the same setup 
running.  I first tried with the official Xen tarballs.  Not successful, I then 
tried yesterday with the FC5 xen kernels.  No success.  The problem in both 
cases is that Suse and Ubuntu guests load but virtual networking does not work. 
 Only lo interface is up.  On the main FC5 xen0 domain, I am able to see vifx.x 
being added as and when a guest boots up, but the guest itself is without an 

Various searches on Google finally got me one hint on loading module xennet 
(for FC5) which I did in modprobe.conf.  Same result.

Search on web got me guides to load guests from images, starting guest installs 
from fedora, debian etc but could not find any info on running already 
installed linux distros within Xen.  The closet was in the xen manual which 
explains how to make an image of an installed linux distro and then running the 
image within xen.

Question:  Is what Iam trying to achieve possibly with Xen 3.x (since it worked 
with 2.x) ?  If yes can anyone help ?  My guest config file is a very simple 
one :

kernel = << Tried both the xen kernel and the FC5 xenU kernel >>
memory = 100
name = "suseguest"
vif= ['mac=aa:00:10:00:00:10, bridge=xenbr0, ip=']
Also tried vif= ['']
gateway = ""
netmask = ""
disk = ['phy:hdc3,hdc3,w']
Also tried disk = ['file:/dev/hdc3,hdc3,w']
root = "/dev/hdc3 rw"

Please note that OpenSUSE is installed on /dev/hdc3

All help is appreciated in resolving this.

Thanks and Best Regards

Check out the latest SMS services @ http://www.linuxmail.org
This allows you to send and receive SMS through your mailbox.

Powered by Outblaze

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.