[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: [Xen-users] NAT wont work in FC4

  • To: <xen-users@xxxxxxxxxxxxxxxxxxx>
  • From: "Mito" <mito@xxxxxxxxxxxxx>
  • Date: Tue, 25 Apr 2006 20:40:33 -0400
  • Delivery-date: Tue, 25 Apr 2006 17:33:58 -0700
  • List-id: Xen user discussion <xen-users.lists.xensource.com>
  • Thread-index: AcZn2sYTHFuj4DHbSVqf1Wtbo509XQA7wlRA

I have tried everything that I can think of, and still can’t come up with something that works.


Has anyone been able to get this to work that can possibly show me what you did?  It doesn’t have to be on any versions of fedora, I just want to be able to see a setup that works so I can compare it to mine to see what’s wrong!





From: xen-users-bounces@xxxxxxxxxxxxxxxxxxx [mailto:xen-users-bounces@xxxxxxxxxxxxxxxxxxx] On Behalf Of Mito
Sent: Monday, April 24, 2006 4:08 PM
To: xen-users@xxxxxxxxxxxxxxxxxxx
Subject: [Xen-users] NAT wont work in FC4


Ok, so I know that there has been a couple of questions asked recently about NAT in Xen, but even after going through those, I still can’t get this to work.


I’m still new to Xen, but I believe what I want to do should be easy, and I can’t figure it out.


The basis behind what I’m doing is as follows:  I am setting up a server to host several different things for me, each in it’s own domU, mailserver, webserver, etc.  Only problem is that I only have 1 static IP from my ISP available, so I need to share them all behind a NAT.  I plan on using my dom0 as a firewall/NAT for all my domU’s.


I originally setup my domU’s under the bridged mode just to get them up and running and make sure everything works.  It all worked well and I was able to access the internet perfectly.  So then I changed it over to the nat scripts that come with Xen and now I can’t get anything working.  I am using FC5 as my domU and my only domU right now is a FC4 system.  I have tried to use this link below even though it’s for debian, but I still can’t get it to work.




Obviously some of those paths (namely the ones for the network configuration files) are different between Debian and FC4, but those only come into play after the networking is actually working, when you want to setup the port forwarding.  I’m not even able to ping out to anywhere, even to the dom0.


On this system I installed Xen from the FC5 rpm’s (via yum).


I don’t get any errors, on any of the configurations, I just can’t get the domU to be able to ping anything.


Any help would be appreciated!




Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.