[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] Error: Device 2049 (vbd) could not be connected. Backend device not found.

On 26 Apr 2006, at 13:26, Joe Warren-Meeks wrote:

Hey there,

I've installed xen 3 and xen-tools on my ubuntu server and all seems well, until I try to start a client domain. (running on Linux xenserver #1 SMP Wed Feb 1 21:23:17 UTC 2006 i686 GNU/ Linux)

Bit of a follow-up. If I try to start the DomU, it initally errors as so:

root@xenserver:/etc/xen# xm create -c squid1.cfg
Using config file "squid1.cfg".
Error: Device 2049 (vbd) could not be connected. Backend device not found.

and then shows up as paused in 'xm list'

If I then attach a console to it, then unpause I see the following error at the end:

VFS: Cannot open root device "sda1" or unknown-block(0,0)
Please append a correct "root=" boot option
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown- block(0,0)

I've tried adding /dev/ nodes using MAKEDEV in both the Dom0 and DomU and tried changing sda to hda, to no avail.

Anyone got a pointer to where I can start looking?


 -- joe.

Joe Warren-Meeks                       T: +44 (0) 208 962 0007
Aggregator Limited                     M: +44 (0) 7789 176078
Unit 62/63 Pall Mall Deposit           E: joe.warren-meeks@xxxxxxxxxxxxx
124-128 Barlby Road, London W10 6BL
PGP Fingerprint: 361F 78D0 56F5 8D7F 2639  947D 71E2 8811 F825 64CC

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.