[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] Error: Device 2049 (vbd) could not be connected. Backend device not found.

On 28 Apr 2006, at 12:32, Abi Chirayil wrote:

Joe Warren-Meeks wrote:

On 27 Apr 2006, at 14:43, Joe Warren-Meeks wrote:

Hey guys,

I've installed xen 3 and xen-tools on my ubuntu server and all seems
well, until I try to start a client domain. (running on Linux
xenserver #1 SMP Wed Feb 1 21:23:17 UTC 2006 i686

Bit of a follow-up. If I try to start the DomU, it initally errors as

root@xenserver:/etc/xen# xm create -c squid1.cfg
Using config file "squid1.cfg".
Error: Device 2049 (vbd) could not be connected. Backend device not

and then shows up as paused in 'xm list'

If I then attach a console to it, then unpause I see the following
error at the end:

VFS: Cannot open root device "sda1" or unknown-block(0,0)
Please append a correct "root=" boot option
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-

I've tried adding /dev/ nodes using MAKEDEV in both the Dom0 and DomU
and tried changing sda to hda, to no avail.

Anyone got a pointer to where I can start looking?

As a futher follow up, if I use xen-create-image to create a new domU, this completes fine and then starts the image successfully! I can then
go and start all the other images and all is fine.

Once I've halted them all and rebooted the server itself, it all stops
working again.

Anyone got any pointers? This is getting quite frustrating.

I'm getting exactly the same error (also using Ubuntu). I just tried
mounting and unmounting the one of the images and that seems to get
everything working - till the next reboot.

mount -o loop /vserver/images/vmNMS.img /vserver/vm_base/
umount /vserver/vm_base/

Any idea why this happens? I've also been pulling my hair out the past
couple of days.

Think I've fixed it.

I read xen-create-image to see why it seemed to work if I used that. Just by an aside I noticed that there is an option of use-ide

So, I've set "use-ide = 1" in /etc/xen-tools/xen-tools.conf and recreated my images and it seems to work now.

I figure that an IDE server has problems trying to run a SCSI domU

I'm creating a bunch of domUs now and rebooting to see if they all start ok. (I also had to up my loopback devices as indicated in another post)

Give it a shot and report back.

 -- joe.

Joe Warren-Meeks                       T: +44 (0) 208 962 0007
Aggregator Limited                     M: +44 (0) 7789 176078
Unit 62/63 Pall Mall Deposit           E: joe.warren-meeks@xxxxxxxxxxxxx
124-128 Barlby Road, London W10 6BL
PGP Fingerprint: 361F 78D0 56F5 8D7F 2639  947D 71E2 8811 F825 64CC

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.