[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re:[Xen-users] Kernel Panic-not syncing VFS: Unable to mount root fs on unknown-block(8, 1)

I was able to fix the same problem without using initrd.
In the menuconfig
device drivers->ATA/ATAPI/MFM/RLL support
   Support for SATA (deprecated; conflicts with libata SATA..
is disabled.
device drivers-> SCSI device support
   SCSI device support 
compiled in the kernel (*)
device drivers-> SCSI device support-> SCSI low-level drivers
   Serial ATA (SATA) support 
compiled in the kernel (*)

Using these configurations it worked for me very well. Wish it helps you too.

>From: Oli Seubert <olizzs@xxxxxxxx>

>I just tried to install Xen (3.0.4) from source.
>The Installation process finished without any errors.

>Then after booting the XEN-Image (without initrd)
>I got a Kernel Panic. My machine said it was unuable to mount root fs from 
Sda1 or unknown-block(0,0)

>After some research on google, I built the SCSI and SATA drivers in the 

>and now this kernel Panic occurs:
>Kernel Panic-not syncing VFS: Unable to mount root fs on unknown-block(8,1)

>After that
>I have tried to create an initrd as suggested in 
>Unfortenetely I wasn't able to compile busybox, so I skipped it

>However when rebooting - no change.

>My machine is a CLFS with CBLFS from linuxfromscratch.org on a notebook with 
intel processor Core 2 Duo T7200 and hardware
> and a fujitsu serial ata disk: PM-FUJITSU MHV2120BH with reiserfs

>Is the missing busybox in initrd the problem? can somebody send me a working 
initr, if initrd needn't be linked to my kernel or binaries?

>I have tried XenExpress on the same machine, which seemed to work well? At 
least it booted.
>So there must be any configuration error?

>Thanks in advance


Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.