[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] fc6 guest x server / vnc problems

  • To: xen-users@xxxxxxxxxxxxxxxxxxx
  • From: "Peter Peltonen" <peter.peltonen@xxxxxxxxx>
  • Date: Wed, 28 Feb 2007 17:22:09 +0200
  • Delivery-date: Wed, 28 Feb 2007 07:21:32 -0800
  • Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=beta; h=received:message-id:date:from:to:subject:mime-version:content-type:content-transfer-encoding:content-disposition; b=KIYW79IWIkiHk3HxQsQOLd0/3dS7/VAFJdL921NlSZH38BlhJk/MYCgm+8SFGRWodm6cNlfz39kSuxm8eAHn8Y/2Os69PLpY1g/NG4b4dVRjtWrj1fiygrwICbd70VIRuW4S93nGlvJ9qWFqFCJJhXf2OVHJTnN17Vb26jGEhIk=
  • List-id: Xen user discussion <xen-users.lists.xensource.com>

I've succesfully installed FC6 domU under RHEL5-beta2 dom0 with
virt-manager. I could open
a graphical vnc console from virt-manager with no probs and use domU's
gnome desktop.

After few days of running the guest I've updated it with yum and been
using it mostly
via xm console. Now I tried to use the graphical console, but all
virt-manager was telling
me was: "The console is currently unavailable."

I searched the fc6 logs and saw these messages:

# tail /var/log/messages:
Feb 28 19:15:20 fc6test pcscd: winscard.c:219:SCardConnect() Reader
E-Gate 0 0 Not Found
Feb 28 19:15:20 fc6test last message repeated 3 times
Feb 28 19:15:22 fc6test gdm[1770]: gdm_slave_xioerror_handler: Fatal X
error - Restarting :0
Feb 28 19:15:26 fc6test gdm[1784]: gdm_slave_xioerror_handler: Fatal X
error - Restarting :0
Feb 28 19:15:30 fc6test gdm[1794]: gdm_slave_xioerror_handler: Fatal X
error - Restarting :0
Feb 28 19:15:30 fc6test gdm[1699]: deal_with_x_crashes: Running the
XKeepsCrashing script
Feb 28 19:15:30 fc6test gdm[1699]: Failed to start X server several
times in a short time period; disabling display :0

# cat /var/log/Xorg.0.log |grep EE
       (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(II) Loading extension MIT-SCREEN-SAVER
(EE) open /dev/fb0: No such file or directory
(EE) No devices detected.

I've tried rebooting both dom0 and domU which has not helped. Is
anyoneone else having these problems? Any ideas how I could solve this

My guest's config looks like this:

name = "fc6test"
memory = "500"
disk = [ 'phy:/dev/mapper/VolGroup00-LogVol02,xvda,w',
vif = [ 'mac=00:16:3e:2e:d0:98, bridge=xenbr0', ]
uuid = "df923cb5-5528-6bd5-c129-2a44656e5584"
on_reboot   = 'restart'
on_crash    = 'restart'


Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.